TEF wouldn't connect in Windows 10 (Solved)

Jayternator's picture

E: This (direct link) solution has worked for me. Big thank you to the person who posted it (as well as Uit for pointing it out to me)!

Hey there. Hope you've all been doing alright.

So about a week ago I got my new computer with Windows 10 and decided that I might as well try to reinstall TEF today.

I did expect some problems, but nothing too hard to fix... The thing is that when and since I first ran the game, the dot stayed red and my connection status showed Error, with Connecting flashing through it very shortly every once in a while. You probably know what I mean.

Aside from running multiple instances of TEF all at once and messing around ingame hoping it'd connect, I have tried running as admin as well as compatibility mode (7, Vista, XP, 98), it wouldn't budge. Tried restarting my computer too.
I think I should also add that I'm running the game from D:, because C: is my SSD and it's not very spacious so I'd really prefer to not have to keep non-essential things there... Although I don't think that's the problem as I tried running from the default install location too and it acted exactly the same. This not-connecting is the only problem I've been having so far, no missing files or anything like that.
I'm beginning to think it could be due to my firewall/antivirus?

I was wondering if someone maybe knows what could be the problem or what else I could try?
I'm not very active anymore but it would be really nice to still be able to enjoy the forest sometimes... Maybe I'm not the only one who's had/is having this problem?

Thank you very much in advance. <3

The signs look like a

The signs look like a server-side glitch I'd get when my deer is stuck on the active list after I log.
Since you've got a firewall, may as well be it. Tried adding TEF into exceptions yet?
Jayternator's picture

Yeah, I was actually a bit

Yeah, I was actually a bit confused because of that as TEF has never been on this computer before.
I tried it as soon as I saw your comment. I was getting excited but it didn't do anything either...
Shey's picture

Like Uit said it's most

Like Uit said it's most likely server-side. I have Windows 10 and it works fine, though, so it's definitely not the OS.
When I'm plagued with the orange dot/no connection, sometimes restarting my router works. Sometimes I can't connect because I have Chrome/other programs that are connected running in the background and have to close them to fully connect.
If you have an FPS limiter turn that off for the Forest, too. Sometimes I run TEF with it and it makes it 1. run a LOT slower than it should, including the connection and 2. It's unnecessary unless you have a NASA supercomputer because I don't think I've ever run TEF above 30 fps when connected, except when playing alone.

Try these maybe?

Looks like somebody had your

Looks like somebody had your problem and we don't know whether they got it figured.
Tried other versions of TEF like the dotd? Connecting under other names? Might shed some light on what is going on server-side.
I used to have a case where one game copy was corrupted and the other able to connect.

E/ Talking about firewalls, check the exceptions of Win's native one, as well.
All else fails, you can enter tracert in the command prompt and see where your connection cuts off.
Jayternator's picture

Thank you both for the

Thank you both for the suggestions. <3

I don't have an FPS limiter, I tried booting it up a few times without any other programs running though. I'll see about the router later, don't want to restart it right now as I have another person sharing my local network and I wouldn't want to cut their internet unexpectedly.

That looks like the exact same problem as I'm having.
I can't connect under other names as I haven't logged into an account on this computer yet. They're stored locally, right? Maybe I could try bringing a copy of whatever file it is that stores them from my old computer.

Last time I tried downloading 3.13 it came with a "trojan horse". Now I feel that it probably was a false positive, but I was a little kid when it happened and man, it thorougly freaked me out, so I'm still a bit anxious thinking about it, especially considering how overprotective I am of my new computer now... I'll keep it as a later resort though.
I tried downloading 3.31, still error but instead of 0 players it showed 37. The firewall where I originally enabled it was Windows' built-in, now I went to check my antivirus' firewall too (I didn't actually think of that before as my old antivirus didn't have its own firewall), and it showed that not only was TEF enabled, there's also been some 2,92 MB of network traffic going on. So it's been trying but kept failing.

Is that the IP of the server? I may end up having to feed that in, but I can't guarantee I'll be able to understand the output as I'm not really that good with computers, haha...

They're stored as

They're stored as Preferences.cgr, yeah. Though it has no relation to the network, worth a shot anyway. In case it is the corrupted game, and not its port.

It is. What tracert does is countdown the stops [IPs] & time it takes to reach the tefc server. The forest being the final point. If it breaks off before hitting that, you'll get to see where.

Another place to get basic info is the Network tab of the Resource Monitor. Pretty intuitive as you can compare your working connects with your 'broken' one.

You've got me on Skype, we can troubleshoot the thing on there in case it is nasty.

What ticks me off is the 37 players note because it's usual we see it when the server is down. And it's working fine today.
Jayternator's picture

The readme file says that

The readme file says that "the screensaver will not work if the application is installed in any other folder than C:\Program Files\Tale of Tales\The Endless Forest 3 but you should be able to run the standalone version from anywhere" although I'm not entirely sure what they mean by standalone version. I've been thinking that maybe I really could've corrupted my game somehow by running it from D:, so I decided to get rid of everything I've had and try to do a clean reinstall, this time leaving everything default. I took my old Preferences.cgr, ran it first without and then with. All it did was show my deer at the location where I logged when I last played, nothing else changed (as I kind of expected at this point, ugh...)

I suppose it's tracert time. You learn something new every day.

Yeah, I'd prefer to continue this on Skype now. At least until we figure it out, so this post isn't constantly bumped.
phantomhelsing's picture

I'm going to just bump this

I'm going to just bump this because people seem to having this problem again lately~
Mythralla's picture

Thank you soooo much!!!! I

Thank you soooo much!!!! I spent hours looking for a solution for my Windows 10 laptop so I could play the game on my laptop as well as my desktop. I'm very happy to have found this. ^_^